This post was published long before the Mists of Pandara Expansion.
The tips and techniques explained here may be outdated.

Craptastic FPS

Six months ago my normal FPS was ~35-60. It was nice. I paid it no attention. It worked and that was all I needed. Somewhere between there and here my FPS took a dump. It’s been ok.. ~20′s but nothing fantastic. I want fantastic.

On Sunday my computer started acting weird. I was getting 5-10 sec lag in Shatt from just standing around.. but when I played a lowbie out in the field I had no problems. I didn’t think a lot of it.. my computer had been left on for a few days.. I figured rebooting would take care of it.

Monday we go and run Kara. I’m still having weird lag. When it lags all of my sounds would loop and stutter for a while. So I tried turning all sound off. Same problem. It made healing on the Nightbane fight very tense when I’d lag out at any time. Eventually I figured out that the massive lag spike happened while lots of spell effect were going off.. oh ho.. that pointed to graphics card problems. I will say that healing Curator while facing a wall is.. well it’s kinda boring. But it did stop the lagging.

I limped through the night in Kara and did OK up until Shade of Aran. There’s too much movement/spell effects and it totally lagged me out. I started checking and the system said the card was fine, not overheated.. but definately something was going on. I popped out the video card and found that 3 of the transistor thingies on the video card had blown up. That seemed.. -bad-. Probably the reason for the lag.

So Tuesday fiancee went to the store and got me a new (bigger better) video card. It’s nice.. I’m back to where I was before the lagging started.. but I’m also back at ~25 fps. That seems .. well it seems really low. (I know at this point all the computer nerds are wondering what hardware I have.. but frankly I don’t know. I’ll update this with that list tonight).

I run a lot of addons. I decided maybe all the addons were screwing with my FPS. So I logged out, moved my Addons folder and logged back into to a totally nude game. It changed my fps from 20-22. I was not impressed. So I put my addons back on.

I dialed all of my in-game video settings down to their lowest setting. It changed my fps from 19-25. Still, not impressed.

I’m not sure what to try now. At this point the difference between the lowest graphics settings and the top graphics settings is about 8-10 fps. Something is wrong.. but I can’t put my finger on it.

[Edited to add:]
Win XP SP2
AMD Athlon 64 Processor 3700+ 2.21 GHz,
2.00 GB of RAM
NVidia GeForce 8500 GT 1gb DDR2

Similar Posts:

11 comments to Craptastic FPS

  • I killed my FPS when I first installed GEM. It subscribes you to the gemdefaultchannel or whatever it’s called. If you uninstall GEM you stay subscribed to that channel and have poor FPS. Only when I reinstalled GEM, subscribed to a made-up channel and removed the default did my FPS recover. Just a thought…

  • Nibuca

    … what’s GEM?

  • ah ok. The Guild Event Manager addon. I guess that isn’t the problem then…

  • How much RAM do you have is another good question I guess. 1GB is the minimum I’d use for WoW, 2GB preferred.

  • It might be a problem with your motherboard or RAM. Try downloading a memory checker and seeing if your RAM is okay.

  • I’ve had similiar problems too. My FPS recently went from an ‘ok but not great’ level of about 22-25 FPS in raids and places like Shatt to a lousy 6-8 FPS. I too thought it was mod related and tried turning off all of mods to no avail. Therefore I recently purchased a new video card and this has improved matters quite a bit. I also have the check box in video options within the game checked that adjusts the quality of the image dynamically to improve frame rates. I forget what the actual name of it is. I also have spell detail set about medium.

    FWIW I am running:
    AMD Athlon 64 3000+
    ASUS K8N-SLI mobo
    2GB DDR RAM
    nVidia Geforce 9600 GT (512mb DDR)

    So actually less powerful than your box. I’m beginning to wonder if something changed in terms of the graphics rendering engine thingy in the last patch since I only noticed the decrease in FPS post 2.4

    I’m no hardware guru though so I have no idea. Hope you get your graphic woes sorted!

  • Check the post on my blog entitled Doomilias is a Genius regarding the changes Blizzard made that may be effecting/affecting your FPS

  • I know that’s latency and not FPS, but you never know…

  • I’m an Aussie playing on Feathermoon so my latency is pretty godawful anyway. FTW I recently set up a utility provided by my ISP that lets me route my packets more directly via their service therefore reducing my latency (all legit and checked out with Blizzard) I went from 400-600ms to around 250ms.

    Therefore I don’t *think* improving latency is going to improve FPS. It is my understanding that the 2 are not really related. But like I said above hardware is not my forte *grin* I may well check out the utility that Doomy recommended and see whether that does make any difference so thanks for the linkage.

  • isaacquotien

    check to see if you have other programs running in the background taking up cpu time.

    do a virus scan…..there maybe some kind of program that is running your cpu at full speed. I had that happen….one day……things are running slow on my computer…..wow fps is terrible……i looked and my cpu was running at 95-100% all the time. I found it was a corrupted HP printer driver of all things….at least when i disable that driver……it dropped to 45-50% cpu time…….couldnt ever figure out the rest…..had to end up reformating and starting over………worked great after that.

    another thought…….be sure to defrag your harddrive….again anything that takes up CPU time is gonna impact your FPS in wow. especially with your setup listed…..you should be doin just fine.

    Hope that helps.

  • I’ve done some googling around and it seems that on the official forums there have been a few complaints of decreased FPS post 2.4. I’ve done the scan thing using my antivirus and spyware progs. Next step will be a defrag but I did find this page with some steps to take from blue which I’ll probably try a few of. Maybe this could help you Mystic if you haven’t seen it already: http://forums.worldofwarcraft.com/thread.html?topicId=174615578&sid=1